[Date Prev][Date Next][Thread Prev][Thread Next] - [Date Index][Thread Index][Author Index]

Re: getting predict compiled (under osx 10.4)




FWIW, I compiled predict last night under Leopard (OSX 10.5)
on my vanilla Core 2 iMac without difficulty. I have the usual
developer stuff that comes with the OS, plus the iPhone SDK
and all the goodies that go with it.

I deleted the include of sys/soundcard.h in installer.c, which
produced a message about it being a bummer that I didn't
have a sound card. Everything else worked, and it ran and
generated predictions without comment. No issues with
ftime(), no need to specify any additional libraries. I didn't
try any of the support utilities.

The GNU-ish way to make programs and their compilation
portable is automake and autoconf.

Laura Halliday VE7LDH "Que les nuages soient notre
Grid: CN89mg                       pied a terre..."
ICBM: 49 16.05 N 122 56.92 W     - Hospital/Shafte
_________________________________________________________________

_______________________________________________
Sent via AMSAT-BB@amsat.org. Opinions expressed are those of the author.
Not an AMSAT-NA member? Join now to support the amateur satellite program!
Subscription settings: http://amsat.org/mailman/listinfo/amsat-bb



AMSAT Top AMSAT Home