[Date Prev][Date Next][Thread Prev][Thread Next] - [Date Index][Thread Index][Author Index]

Strainge audio input problems on my laptop



Dear AMSATs,

Since a long time I have a strainge problem with my
ASUS L8400 laptop computer. The problem is with the
audio input signals (mic and line-in) that are
distorted in software programs, but when I hear it
directly at the speakers it is off excelent quality.

The problem I noticed for a long time ago (~1 year)
but it was no real problem then. Now I was doing some
test with SSTV again and "bumped" again to this
forgotten problem. I started a small investigation to
find the problem so I can use my laptop for ham radio
again.

Unfortunatly even after many hours of testing I still
have no clue where is the probem. The operating system
I use is WIN98, and the audio chip set is said to be
"ESS Allegro"

When I put a mic on the mic-input and a speaker on the
output I can hear my voice very well out of the
speakers, mixed with CD music and all windows sounds.
The problems apears when I want these sounds to be
used in a software application, like in ham
applications or the audio recorder of WIN98 etc...

When I record the sounds in the windows audio recorder
she signals from the mic are very distorted and only
the peaks of a very loud sound get through.
I have been testing with different mic levels (on the
audio control panel) and I discovered that when I put
the level of the mic at half to maximum level then
other audio sources (like CD or windows sounds) get
also distorted. These sounds seem to get the same
problem. 

The problems I see only happen in the software
aplications. E.g I can hear the CD-music excellent in
real, but when I later listen back a record of the
sound it is distorted when the mic level is maximum.
When I put the mic level to about less than half the
recorded CD music is normal again.

I installed the audio drivers several times from the
original CD, and also tried it with a download from 
internet, but the problem stays...
It might be the hardware, but then I wonder why I can
clearly hear my voice out of the speakers.
For me this means the mic amp is okay... 

Maybe there is a problem with the ADC's what I hardly
believe because there is still an amplifier in
front of the ADC's...

Unfortunatly I am not well known with those digital
soundblaster electronics in computers... 
These days ham radio is full of sound-blaster
modulations, and I hope some of you have any idea what
is the problem and how to solve it... I also would
like to know how these audio channels are switched and
mixed in these ESS Allegro chips... Maybe it might
give a clue where the problem is...

73 de PE1RAH
William Leijenaar
---
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
----
Sent via amsat-bb@amsat.org. Opinions expressed are those of the author.
Not an AMSAT member? Join now to support the amateur satellite program!
To unsubscribe, send "unsubscribe amsat-bb" to Majordomo@amsat.org



AMSAT Top AMSAT Home