[Date Prev][Date Next][Thread Prev][Thread Next] - [Date Index][Thread Index][Author Index]

SV: Re: Icom preamps fault / icom UT-50 tone unit wanted



Hi guys, if my memory serves me right (YES, I am THAT old, hi) u may be able to replace 3SK121 
with one called 40673 that has built-in protection diodes (2 pcs back-to-back), BUT...........
if that is easier to find, i don't know.

vy 73 de OZ4UI / Lars


-----Oprindelig meddelelse-----
Fra:	Paul Luggar [SMTP:luggsey@hotmail.com (REMOVE)]
Sendt:	21. april 2004 19:46
Til:	amsat-bb@AMSAT.Org; wa6ilt@AMSAT.Org
Emne:	[amsat-bb] Re: Icom preamps fault /  icom UT-50 tone unit wanted

Hi Dave/Walt, thanks for the replys. I have tried all the obvious things
like the rig supply, switch etc but your thoughts about sending RF and
Voltage at the same time rang a bell!  I used a dc inserter when I first got
these pre-amps and I suppose that left DC on the co-ax along with RF!  I was
being careful to protect my rado just in case the Amps were faulty...doohhh!

I suppose this must have taken out the GasFet, everything else should be ok
as the IC is still putting out 8V.
Out of interest what was the damage to your pre-amp?
I will still have  find a source for 3SK121 GasFets by the sound of it!

I'm still looking for an Icom UT-50 tone unit if anybody has one fo sale.

Paul

M3SCI


----
Sent via amsat-bb@amsat.org. Opinions expressed are those of the author.
Not an AMSAT member? Join now to support the amateur satellite program!
To unsubscribe, send "unsubscribe amsat-bb" to Majordomo@amsat.org



AMSAT Top AMSAT Home