[Date Prev][Date Next][Thread Prev][Thread Next] - [Date Index][Thread Index][Author Index]

Re: RE: UT 2003 on a PCI parallel port?



Alan,

    I have dealt with PCI based parallel ports in many machines.  What you
are wanting to do should not be too tough.  When you are done the software
will not know or care if the parallel port is on the motherboard or plugged
into a PCI slot.  All the software needs to know is where to send and
receive messages.  Give this a try:

Completely remove the PCI card.
Start the machine and go through to Windows.
Acknowledge the board has been removed, etc.
Shut the machine down.
Put the PCI board containing the parallel port(s) back in.
Start the machine.
Let 'Plug-n-Play' find the board.
Install the board exactly as the manual with the board states
(use the manufacture's driver for WinXP if you have it).

Restart the machine.

In WinXP click on Start
(Click will always mean Left Mouse Button for Right handed config)
click Control Panel
double click System
click the "Hardware" tab
click "Device Manager" button
click the + in front of "Ports"
right click (the other mouse button) the parallel port you just added
click on "Properties"
click on "Port Setting" tab
use the drop down box to set whatever Lpt# you want the new port to be
click on the "Resources" tab
uncheck the "Use Automatic Settings" box
at this point you can set the port to use whatever address you want
(write memory locations before you start changing them!)
click OK to save your changes

Restart the machine.  It will tell you if there are any conflicts.  If there
are conflicts use the same process to move the address of the conflicting
device.  Be aware some old software assumes certain devices to be at certain
memory locations (write memory locations before you start changing them!).
Let XP do the PCI stuff all you need is a parallel port that your software
can talk to, and this should do it.


73,
Joe
ks5z
ex-ka0yos





----- Original Message ----- 
From: "Alan P. Biddle" <APBIDDLE@att.net>
To: <dbwoodw@alltel.net>; <amsat-bb@AMSAT.Org>
Sent: Wednesday, December 10, 2003 10:33 AM
Subject: RE: RE: [amsat-bb] UT 2003 on a PCI parallel port?


> Dave,
>
> Thanks for the suggestions.  Basically I have been trying to match up
things
> as you suggested.  However, the PCI is not available from BIOS, and the
WIN
> XP system resources are grayed out, as is the check box to allow manual
> entry.  Also, unlike a normal mobo port, or a second ISA port, it shows
> multiple sections of address space for the PCI card.  None of the address
> lines match the usual address space used for LP ports.  The docs which
come
> with the SST driver _seem_ to say it requires direct access, rather than
> through a PCI card.
>
>
> Alan
> WA4SCA

----
Sent via amsat-bb@amsat.org. Opinions expressed are those of the author.
Not an AMSAT member? Join now to support the amateur satellite program!
To unsubscribe, send "unsubscribe amsat-bb" to Majordomo@amsat.org



AMSAT Top AMSAT Home